Thursday, April 10th 2008


More Media Temple D/V: Installing YUM (Yellow dog Updater, Modified)
posted @ 7:08 am in [ Media Temple -Technology -Web Design ]

I know I said below that you can just Google how to do this, but then I had to do it again today on a client’s server, and actually nobody has the correct instructions for the 4.5 version of CentOS that is installed on Media Temple Dedicated Virtual servers (D/V) by default.

So, the basic principle is that YUM needs sqlite, the sqlite libraries for python, a few other python things like elementtree and urlgrabber and then YUM itself. Grab the libraries you want from the CentOS vault and then install them (you need to get your root password for this – control panel request the lovely people at M/T if you don’t have it) and the rest should be easy….

export MIRROR=http://vault.centos.org/4.5/os/i386/CentOS/RPMS/
wget ${MIRROR}python-sqlite-1.1.7-1.2.1.i386.rpm
wget ${MIRROR}sqlite-3.3.6-2.i386.rpm
wget ${MIRROR}python-urlgrabber-2.9.8-2.noarch.rpm
wget ${MIRROR}python-elementtree-1.2.6-5.el4.centos.i386.rpm
wget ${MIRROR}yum-2.4.3-3.el4.centos.noarch.rpm
wget ${MIRROR}libxml2-python-2.6.16-10.i386.rpm
wget ${MIRROR}rpm-python-4.3.3-22_nonptl.i386.rpm

rpm -Uvh python-elementtree-1.2.6-5.el4.centos.i386.rpm
rpm -Uvh python-urlgrabber-2.9.8-2.noarch.rpm
rpm -Uvh sqlite-3.3.6-2.i386.rpm
rpm -Uvh python-sqlite-1.1.7-1.2.1.i386.rpm
rpm -Uvh rpm-python-4.3.3-22_nonptl.i386.rpm
rpm -Uvh libxml2-python-2.6.16-10.i386.rpm
rpm -Uvh yum-2.4.3-3.el4.centos.noarch.rpm

Bing! YUM ready to roll and add all those other things you need (for us were installing MySQL 5 so that we can have VIEWs :-))